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TECHNICAL REQUIREMENTS 
Make sure you meet all system requirements before proceeding with EFS PASAT. 
 Minimum Recommended for best results 

Processor Pentium II 266 MHz Pentium III 500 MHz or higher 
Memory 64 MB RAM 128 MB RAM 
Screen Display 800 x 600 1024 x 768 or higher 
Free Hard Disk Space 70 Megabytes 100 Megabytes 
Plug-in AlternaTIFF v1.3.5 TIFF Viewer Plug In. 
Browser Internet Explorer 5.5 or greater 
Internet Connection 56Kbps or faster modem 
Operating System Windows 95 (with Service Pack 1 or greater)/ 98 (with 

Customer Service Pack or Second Edition)/ NT (4.0 with 
Service Pack 3 or greater)/ 2000 

Scanner Capable of producing black and white TIFF images at 300 dpi; 
CCITT Group 4 compression 

Applications Microsoft Word 97 (with Service Release 2 or higher), or 
Microsoft Word 2000 including Office Assistant 
Windows Imaging 
Up-to-date Printer Driver (s) 
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INTRODUCTION 
Patent Application Specification Authoring Tool (PASAT) is used to author electronic 
(XML) versions of patent application specifications. 

The PASAT Process 
XML documents consist of the following components: 

-    Content – text, titles, pictures, etc. 
-  Structure – the organizational form that determines which content objects are 
permitted at any point in a document, as well as how these objects are displayed in 
various viewers (such as Internet Explorer)  

For the XML document to be valid, its structure must adhere to the Document Type 
Definition (DTD) the document refers to.  
Physical representation of the structure in an XML document is markup – start and end 
tags that wrap each element in the document. Markup can be simple, such as for 
paragraphs (<paragraph> Paragraph text </paragraph>), or complex, such as for tables. In 
any event, creating a valid XML document with the use of XML means requires certain 
degree of proficiency. 
PASAT enables you to create patent specifications in the XML format required by 
USPTO with little or no XML knowledge. You are using the familiar MS Word with a 
slightly modified interface to create a specification, and then PASAT exports it as an 
XML instance.  
As you edit specifications, behind the scenes PASAT handles the XML-required structure 
of the document based on the USPTO Document Type Definition (DTD) and Stylesheet 
(XSL file). An overview of the USPTO DTD is given in Appendix A.  
Generally, the PASAT workflow is: 

1. Import an XML document, Load a PASAT file or create a New specification. 

2. Edit the contents of the specification. 

3. Save the specification (when and if needed) as .s4w file for future editing. 

4. Validate the specification against the USPTO DTD and correct the errors revealed.  

5. Optionally, preview the specification as an XML instance in an Internet browser. 

6. Export the specification as an XML instance ready for submission to USPTO. 

This Authoring Guide assumes that you are familiar with MS Word 97 and with the 
traditional paper-based patent application specification authoring process. Therefore, it 
describes only the PASAT-specific procedures required for creating patent specifications 
as XML instances.  
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Each section of this manual includes: 

- A brief overview of an operation to clarify why and when the operation is 
    performed. 
- Step-by-step instructions. 
- System responses. 
- Examples. 
- “Behind the scenes" notes that summarize the XML activities PASAT performs 
   behind the scenes. 

Conventions Used in This Manual 
The following list contains the conventions used in this manual to represent common 
terms, emphasize items, and help you identify certain text.  

- Italic indicates emphasis, e.g., "All Specifications must be successfully validated  
   before they are submitted." 
- Bold Italic indicates that an item is found in the glossary list (See Appendix A). 
   The first instance of a term in a section appears in bold italic, e.g., "WordPerfect  
   validates your Specification document against a DTD." Subsequent instances  
   appear as normal text.  
- Text contained within angle brackets indicates the name of an element or tag, e.g., 
   "the <paragraph> element". 
-A series of pop-up menu selections is written as 
 Start/Programs/Accessories/Imaging. This means click on the Start button and 
 move the cursor to Programs in the pop-up window, then to Accessories in the 
 next pop-up window, and finally click on Imaging in the last pop-up window. 

 

Note: … Text with a Note box contains helpful hints you may use to aid the authoring 
process. 

Behind the Scenes, PASAT Notes that summarize the XML activities PASAT performs behind the 
scenes. 

This symbol indicates that the included text is additional information that 
may be helpful to you.  

This symbol is used to stress a warning or reminder. 
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INSTALLING PASAT 

Installation Process 
The general procedure for installing PASAT v. 4.0 is: 

1. Uninstall any previous versions of PASAT. 

2. For Windows 98 only, ensure you have Windows 98 Second Edition (SE) or 
Windows 98 with the Customer Service Pack installed. 

For Windows 95 only, ensure you have Windows 95 Service Pack 1 or greater 
installed. 

For Windows NT only, ensure you have Windows NT 4.0 Service Pack 3 or 
greater installed. 

3. Ensure you have Windows Imaging. 

4. Install the latest version of AlternaTIFF. 

5. Install PASAT v. 4.0. 

6. For Word 2000 only, ensure the Microsoft Word 2000 macro security level is set 
to Low. 

For Word 97 only, ensure Microsoft Word 97 has Service Release 2 or greater 
installed. 

7. Ensure the Office Assistant is enabled. 

PASAT v. 1.1 Uninstallation 
If you have a previous version of PASAT installed, you must uninstall it prior to 
installing PASAT v. 4.0. To uninstall a previous version of PASAT, do the following: 

1. From the Start menu, select Settings, then click Control panel. 

2. Double-click Add/Remove Programs. 

3. Select PASAT and click Change/Remove. 

4. In the Welcome dialog, select Remove, and click Next. 

5. When asked if you want to completely remove the application, click Yes. 

6. If the Shared File Detection dialog appears, click Yes to delete the file specified, 
or No to keep the file. 

7. In the InstallShield Wizard Complete dialog, click Finish. 
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8. When asked if you would like to delete log files, click Yes to delete the files, and 
No to keep them. It is recommended that you keep these files if you have had 
problems with PASAT. 

Windows 98 Second Edition, or Windows 98 with Customer Service Pack 
(For Windows 98 Only) 
Prior to installing PASAT v. 4.0, ensure that the Windows 98 version you have is either 
Second Edition or has the Customer Service Pack installed. To check for these 
requirements, do the following: 

1. Right-click the My Computer icon on the desktop. 

2. Select Properties. 

3. Note the version of Windows 98 or whether it has the customer service pack 
installed. 

If you do not have Windows 98 Second Edition or Windows 98 with the customer service 
pack installed, you can download the customer service pack from: 

http://www.microsoft.com/Windows98/downloads/default.asp 

Windows 95 Service Pack 1 
(For Windows 95 Only) 
Prior to installing PASAT v. 4.0, ensure Windows 95 Service Pack 1 or greater is 
installed. To check for service packs, do the following: 

1. From the Start menu, go to Settings, then to Control Panel, and select System. 

2. Select the General tab, and note the Windows 95 version. 

If the version is listed as 4.00.950, you do not have service pack 1 or greater installed. In 
this case, download it from: 

http://support.microsoft.com/support/servicepacks/Windows/95/ 

Windows NT 4.0 Service Pack 3 
(For Windows NT Only) 
Prior to installing PASAT v. 4.0, ensure Windows NT 4.0 Service Pack 3 or greater is 
installed. To check for service packs, do the following: 

1. Double-click the My Computer icon on the desktop. 

2. From the Help menu, select About Windows. 

3. Note the service pack (SP). 

If you do not have service pack 3 or greater installed, you can download it from: 
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http://support.microsoft.com/support/servicepacks/WinNT/4.0/ 

Windows Imaging 
Windows imaging is used to view and print TIFF images, which is the graphic format 
used by PASAT v. 4.0. To ensure you have Windows Imaging installed, do the 
following: 

1. From the Start menu, go to Programs, then Accessories. 

2. Ensure Imaging is listed under the Accessories folder. 

AlternaTIFF TIFF Viewer 
AlternaTIFF is required for viewing images in specifications in Internet Explorer. If you 
do not have AlternaTIFF, and want to be able to view TIFF images in your specification 
in Internet Explorer: 

1. Open your web browser and navigate to http://www.alternatiff.com/ . 

2. Download and install the latest version of AlternaTIFF. 

PASAT v. 4.0 Installation 
Before installing PASAT v. 4.0, it is highly recommended that you shut down any 
applications that may be running on your machine. 

To install PASAT v. 4.0, do the following: 

1. Double-click the Pasat.exe file. 

2. In the Welcome dialog that appears, click Next. 

3. In the License Agreement dialog, click Yes to accept the License Agreement. 

4. In the Choose Destination Location dialog, click Next to accept the default 
installation location. 

To select an alternate location, click Browse, select an installation location, click 
OK, and then click Next in the Choose Destination Location dialog. 

5. In the Setup Type dialog, select the type of setup you want, and then click Next. 
The default is Typical, which is recommended. 

6. In the Select Program Folder dialog, click Next to accept PASAT as the PASAT 
program folder name. 

To use another name, either enter it in the Program Folders text box, or select one 
from the Existing Folders list, and then click Next. 

7. In the InstallShield Wizard Complete dialog, click Finish to restart your computer. 

To restart your computer manually later, select No, I will restart my computer 
later, and then click Finish. 
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Microsoft Word Macro Security Level 
(For Word 2000 Only) 
Prior to using PASAT v. 4.0, you must ensure the Microsoft Word 2000 macro security 
level is set to low. To do this: 

1. Open Microsoft Word 2000. 

2. From the Tools menu, go to Macro and then click Security. 

3. From the Security Level tab, ensure Low is selected. 

Microsoft Word 97, Service Release 2 or greater 
(For Word 97 Only) 
PASAT v. 4.0 requires that Microsoft Word 97 must have service release 2 or greater 
installed. To ensure you have service release 2 or greater installed, do the following: 

1. Launch Microsoft Word 97. 

2. From the Help menu, select About Microsoft Word. 

3. Check the service release (SR). 

If you do not have service release 2 or greater installed, you can download it from: 

http://office.microsoft.com/Downloads/9798/sr2off97detail.aspx 

Office Assistant 
Prior to using PASAT v. 4.0, you should ensure the Microsoft Word Office Assistant is 
enabled. 

To do this: 

1. Open Microsoft Word. If the Office Assistant is visible, it is enabled and you may 
proceed with the next section. Otherwise, continue with the next step. 

2. From the Help menu, select Show the Office Assistant. 

PASAT v 4.0 Uninstallation 
PASAT v. 4.0 is easily uninstalled at any time. This section provides instructions for 
uninstalling 
After PASAT 4.0 is uninstalled, there might still be S4 references in the Visual Basic 
editor. Note that these references are not selected, and will not affect Microsoft Word in 
any way. 
To uninstall PASAT v. 4.0: 

1. From the Start menu, select Settings, then click Control panel. 
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2. Double-click Add/Remove Programs. 
3. Select PASAT and click Add/Remove. 
4. In the Welcome dialog, select Remove, and click Next. 
5. When asked if you want to completely remove the application, click Yes. 
6. If the Shared File Detection dialog appears, click Yes to delete the file specified, 

or No to keep the file. 
7. In the InstallShield Wizard Complete dialog, click Finish. 
8. When asked if you would like to delete log files, click Yes to delete the files, and 

No to keep them. It is recommended that you keep these files if you have had 
problems with PASAT. 
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KEYS TO A “STRESS-FREE” ELECTRONIC SUBMISSION 
1. Get your Customer Number and PKI Digital Certificate 
2. Scan or convert all images (using settings specified – 300x300 dpi, Black & 

White, CITT Group 4 Compression, 8 ½ x 11 in. for drawings and forms) 
a. Inline graphics 

i. Complex Chemical Structures 
ii. Math Equations 
iii. Tables 
iv. Custom Characters 

b. Drawings (Figures) 
c. Declaration Forms 
d. Assignment Documents 
e. Small Entity Statements 

3. Naming your files and folders: 
a. File names are limited to 25 characters and MUST be Alphanumeric 

a. The “8.3” file naming convention is recommended 
b. 8=the file name; 3=the file extension (*.wpd, *.s4t, *.doc, etc) 

b. Attached files and submission folders should not contain special characters 
(e.g. &, #, %). Please provide alphanumeric characters, underscores and/or 
dashes. 

c. When creating your ePAVE submission folder, the submission folder name 
MUST differ from the names of any submission files/figures that will be 
included in the submission 

4. If authoring from a source document(s), convert source document text to Arial, 
CG Times or Times New Roman 

5. Create a working or “source” document folder on a local or shared drive to store 
all files relating to the submission 
Note the file naming convention mentioned above 

6. Copy all specification-related files into this folder: 
a. All images (see list above) 
b. Source document(s) 
c. The PASAT authored specification will be saved in this location 
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IMPORTANT NOTE: Once you have begun authoring your specification, 
DO NOT move any files from this folder. 
Example: Images inserted into a PASAT document are NOT embedded in the 
document. There is a HYPERLINK created to the file path of the image. If the 
image is moved from the folder once it has been inserted into the PASAT 
document, the hyperlink will not be able to find its path. 

7. Launch your source document 
8. Launch PASAT 

a. Author Specification 
-    Save Specification 

b. Validate 
-    Edit and/or Save Specification 

c. View/Export 
-    Edit and/or Save Specification 

9. Launch ePAVE 
a.   Author 
b.   View/Print 
c.   Submit 
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GETTING STARTED 

Preparing a Patent Application in PASAT 
1.  Scan or convert all graphics to CCITT Group 4 Compression TIFF images. 

-    Chemical or mathematical formulae 
-    Figures of drawings 
-    Tables 

2. If using source document(s), convert source text to CG Times or Times New Roman. 
3.  From the File menu create a new application by selecting New Specification. 
4.  Select the sections that you want to include in your application. 

 
Create New Specification Window 

5.  Type your specification directly into PASAT. 

OR 
Copy-and-paste text from an existing source document into PASAT. PASAT will 
enter the XML tagging for paragraphs, superscripts, subscripts, and translate 
symbols into the specification. In the Claims section, PASAT will enter that claim 
tagging for your claims. 
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Part of the Claims Section of a Specification – Unnumbered 

6.  Attach your Figures of drawings using the Figure Manager. 

 
Figure Manager Window 

7.  From the Tools menu, use the Renumber feature to renumber your paragraphs, 
claims, and tables. 
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Part of the Claims Section of a Specification - Numbered 

8.  Use the Validation feature to check your specification for any errors. 

 
Validation Report Window 

9.  Save your tagged specification by choosing Save Specification from the File menu. 
10.  Preview your XML specification by choosing the Preview icon on the tool bar. 
This will launch Internet Explorer and allow you to view and print your specification. 

 

Part of the Detailed Description Section of a Specification - Numbered 
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11.  Save your final XML tagged specification by selecting Export Specification from the 
File menu. 

Note: Non-required sections can be added to/deleted from the specification at any time 
during the editing process. For details, refer to the Editing Specification Sections section. 
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INTERFACE FEATURES 
Once you have loaded, imported, and/or created a new specification, the PASAT features 
come into play. Some of them are visible in the MS Word window; some are hidden 
behind the scenes. This chapter offers a brief overview of these features. Their use is 
described in detail in the subsequent chapters. 

PASAT Shortcuts 
After you have installed PASAT on your machine, the PASAT shortcut appears on your 
desktop. When you use this shortcut, MS Word launches with the following new options 
in the File menu: 
-   New Specification – prompts you to define the skeleton for the new Specification, then  
    displays the new Specification as an MS Word document 
 
-   Load Specification – loads a Specification saved as .s4w file and displays it as an MS 
     Word document 
 
-   Save Specification (grayed out/unavailable) – saves the current Specification as .s4w 
     file (for details, refer to the Saving Specifications section) 
 
-   Import XML Specification – imports an XML instance and displays it as an MS Word 
    document 
 
-   Export XML Specification (grayed out/unavailable) – exports the current Specification  
    as an XML instance (for details, refer to the Exporting Specifications section) 
 
By selecting the New Specification, Load Specification or Import XML Specification 
option, you initiate the PASAT workflow, which is described in the subsequent sections.  
If you select the New or Open option from the File menu, or click the New or Open 
toolbar button, the application returns control to MS Word and your regular Word menus 
and settings take precedence. 

Creating New Specifications 
To create a new specification from scratch: 

1. From the File menu, select the New Specification option, and the Create New 
Specification dialog is displayed (see below). 
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Create New Specification Window 

This dialog includes all sections allowed in a specification by the DTD. The required 
sections are shown in bold. By default, all required sections are selected (and can not be 
deselected). 

1. To include a section in the specification you are going to create, click the check 
box adjacent to its name. 

2. After all additional sections for this application have been selected click OK. 
The new specification is displayed in the MS Word window in the Tags Off mode (looks 
like a regular MS Word document), ready for editing. The document layout includes the 
titles of the sections you have selected. 
Behind the scenes, PASAT 

-     Creates a skeleton specification with the sections you have selected.  
-     Inserts the appropriate XML elements into the instance, according to the DTD. 
-     Applies the formatting template to the new document. 

*.s4w File with Extra Sections after First Specification End Tag 
User authored a specification in Windows 2000 with Word 2000. PASAT created an 
*.s4w file with an extra claims section, abstract section, and figures section after the first 
end specification tag. 
Following the extraneous sections, there was an end specification block tag and a second 
end specification tag. The document validated and was successfully exported to XML 
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without the extra sections. The extra sections could not be removed. Attempting to 
remove them caused a Winword error and required PASAT to be restarted. 

Importing Specifications 
To import a specification that has been exported as an XML instance: 

1. Select the Import XML Specification option from the File menu, and the Import 
XML Instance dialog is displayed (see below). 

 
Import XML Instance Window 

2. In the dialog, locate the XML file you want to import and click Open. 
If the selected XML file is valid (conforms to the USPTO DTD), it is displayed in the MS 
Word window in the Tags Off mode (looks like a regular MS Word document), ready for 
editing. If the instance is invalid, the import aborts and the appropriate warning is 
displayed.  
Behind the scenes, PASAT 

-     Validates the selected XML file against the USPTO DTD 
-     Resolves graphic references 
-     Applies the formatting template to the document 
-     If the selected .xml file is invalid, generates the Error Log file 
 

Note: The XML instances that failed to import, along with the corresponding Error Log 
files, should be sent to your technical support organization. Error Log files are generated 
in the same directory and with the same name as the original .xml files, but with the 
extension .err (<name>.err).  
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Loading Specifications 
To load a specification that has been saved as .s4w file:  

1. Select the Load Specification option from the File popup menu, and the Load 
Specification dialog is displayed. 

 
Load Specification Window 

2. In the dialog, locate the specification (.s4w file) you want to load and click the 
Open button. 

The selected specification is displayed in the MS Word window in the Tags Off mode 
(looks like a regular MS Word document), ready for editing. 

Popup Menus and Menu Options 
Although the names of popup menus on the menu bar remain the same as in MS Word, 
some of the menu options are renamed, removed, added or modified. 

File Menu 
The added options are described in Saving and Exporting Specifications, with the 
exception of Preview in Browser, which creates a temporary XML instance of the 
current specification and displays it in your default Internet browser. 
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Edit Menu 

-  Undo – reverses the last operation on the Undo list (up to 6 operations) 
-  Cut – copies the current selection (content and markup) to the clipboard and deletes  
    it from the original location 
-  Copy – copies the current selection (content and markup) to the clipboard 
-  Paste – pastes the clipboard content (excluding markup) at the specified location 
-  Paste Structure – pastes the clipboard content (including markup) at the specified 
    location 
- Paste Table – pastes non-structured tables (copied from regular MS Word 
    documents) at the cursor location in the specification; converts the pasted table to a 
    structured table, with all necessary tags inserted  
- Paste Paragraph(s) – pastes the clipboard content at the specified location as 
    multiple paragraph elements (text wrapped in the paragraph tags), split at hard  
    returns 
-  Paste Claim(s) – pastes the clipboard content at the specified location in the Claims 
    section as multiple claims (text wrapped in the claim and claim-text tags), split at  
    hard returns 
-  Find – displays the Content Find and Replace dialog (the Find page) 
-  Replace – displays the Content Find and Replace dialog (the Replace page)  

View Menu 
-  View Tags – toggles between the Tags Off and Tags On display modes of the 
      specification 
-   View Entities - shows/hides entity names 
-   View S4/Guide - shows/hides the Office Assistant 
-  Document Map – shows/hides the Specification Map (a tree of the specification 
     sections and elements) at the left-hand side of the MS Word window 

Insert Menu 
-  Symbol – displays the Symbol dialog that enables you to insert HTML 4.0 named 
    character entities at the cursor location 
-  Picture – displays the Figure dialog that enables you to insert graphics at the cursor 
    location 

Tools Menu 
-  Renumber – renumbers paragraphs, claims, or both starting from the beginning of 
    the specification 
-  Edit Sections – displays the Edit Specification Sections dialog that allows sections 
    to be added to/deleted from the specification at any time during the editing process. 
-  Validate Instance – validates the structure of the specification against the USPTO 
    DTD and highlights the first error to be corrected 
-  Spelling – initiates the Batch Mode content spell-checker  
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Table Menu 

-  Insert Table – prompts you to define the table type (scanned or MS Word table)  
    and (for MS Word tables) size, then inserts the new table at the specified location 
- Convert Table – toggles between the rendered and unrendered display of the 
    selected table 
-  Insert – inserts a new row or column 
-  Delete – deletes the row or column that contains the insertion point 
- Split Cell – splits the selected table cell that was merged previously into the original  
   two cells 
- Merge Cells – merges the two selected table cells  

Toolbars 
Following is the description of the PASAT options available from toolbars. 

File 

  
Buttons on this toolbar duplicate the PASAT-specific options available from the File 
popup menu. Left to right on the bar: 

- New Specification 
- Load Specification  
- Save Specification  
- Import XML Specification  
- Export XML Specification  
- Print Specification 
- Print Preview Specification 
- Spell Check Specification 
- Preview in Browser 
- Show/Hide XML tags 
- Show/Hide Specification map 
- Help 

Edit 

 
Buttons on this toolbar duplicate the PASAT-specific (new or modified) options available 
from the Edit popup menu. Left to right on the bar: 

- Cut  
- Copy  
- Paste 
- Undo 
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Format 

 
Left to right on the bar: 
- Italics - will appear as italic text when viewing text in PASAT. When viewing the same  
   text in web browser using the USPTO standard style sheet for the specification the text  
   will appear in italics. 
 
- Superscript – converts the selected text to superscript or inserts superscript formatting 
   at the cursor location, so that the content you type in appears as superscript. If the  
  cursor is in a superscript section, PASAT removes superscript formatting from this  
  section.  
 
- Subscript – converts the selected text to subscript or inserts subscript formatting at the 
   cursor location, so that the content you type in appears as subscript. If the cursor is in a  
   subscript section, PASAT removes subscript formatting from this section. 
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Indentation 

 
Claim-text elements support five levels of indentation. The buttons on this toolbar enable 
management of the claim-text indentation. Left to right on the bar: 

- Decrease Indent – moves the selected claim-text element one indentation level left 
- Increase Indent – moves the selected claim-text element one indentation level right 

File Menu in PASAT 
Launch PASAT and select a new specification. This builds the specification including 
edits, tables, etc. In the Tools drop down menu there are no choices. The functionality is 
available in the Office Assistant but not in the file menu. Windows NT service pack 5, 
Word 97. No templates or add-ins. 

Insert List 
The Insert dropdown list is located at the right-hand side of the PASAT toolbar: 

 
Insert drop down list 

In the course of the specification editing, you select the elements to be inserted from this 
list. The list options changes so that you can only select those elements that are allowed 
at the current cursor position in the document (according to the DTD). 

Shortcut Keys 
The following shortcut keys are also part of the PASAT interface: 

Ctrl+b – duplicates the Bold toolbar button 

Ctrl+x – duplicates the Cut option on the Edit menu 

Ctrl+c – duplicates the Copy option on the Edit menu 

Ctrl+v – duplicates the Paste option on the Edit menu 

Ctrl+z – duplicates the Undo option on the Edit menu 

Enter – splits a paragraph or a claim-text element at the cursor position 
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Ctrl+o – opens regular MS Word document 

Ctrl+- – duplicates the Superscript toolbar button 

Ctrl+= – duplicates the Subscript toolbar button 

Ctrl+f – initiates the Find and Replace function 

Ctrl+Shift+v – initiates the Paste Structure function 

Ctrl+l – pastes claims or paragraphs 

Ctrl+r – repeats last Insert Symbol operation 

Ctrl+y – displays the Symbol Manager dialog 

Ctrl+s – saves specification 

Ctrl+t – toggles tag display mode 

Ctrl+Left Arrow – as in MS Word 

Ctrl+Right Arrow – as in MS Word 

Ctrl+Up Arrow – as in MS Word 

Ctrl+Down arrow – as in MS Word 

Ctrl+Enter – splits claim or paragraph at the insertion point; in a claim, splits the 
entire claim where a regular Enter key splits the current claim-text element only; in a  
paragraph, creates a new paragraph 

 
F1– initiates Online Help  

F7 – initiates Spell Checker  

Crtl F5 – renumbers all paragraphs and claims in the specification  

Crtl F6 – initiates the Validate Document function  

Crtl F7 – initiates the Preview in Browser function  

Crtl F8 – exports the specification as XML instance  

Tab – in tables, works as in MS Word 

Home – as in MS Word  

Crtl+End – as in MS Word 

Crtl+Home – as in MS Word 

Shift+Home – as in MS Word 
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Office Assistant 
When working with PASAT, the familiar Office Assistant feature provides you with 
context-sensitive PASAT help. 

 
Office Assistant options for a Standard Paragraph Section in PASAT 

The top line in the Assistant callout tells you what element the cursor is currently in 
(Paragraph, Claim, etc.). The bulleted list enables you to initiate the most common 
operations allowed at the current cursor position. 

Status Bar 
The Status Bar in the top right section of the MS Word window displays the "ancestry 
line" of the element the cursor is currently in. 

Example 
The cursor is within a paragraph, which is a part of the Abstract of Disclosure section, 
which is a part of the Specification Block, which is a part of the Specification. The Status 
Bar reads: specification|specification-block|abstract-of-disclosure paragraph. 

 

Disabled MS Word Features 
The following MS Word features are disabled in PASAT in order to facilitate the XML 
activities behind the scenes: 

- AutoCorrect 

- AutoFormat As You Type 
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- AutoFormat 

- AutoText 

- Fast Save 

- Background Save 

- Drag and Drop Editing 

- Automatic Word Selection 

- Insert Key for Paste 

- Smart Cut and Paste 

- Allow Accented Uppercase 

- Indent Set by Tab Key 

- Create Backup Copy 

- Track Changes 

 

Note: The AutoRecover feature is not disabled. However, you should be aware of the fact 
that the recovered documents will not contain any of the XML markup. They will be just 
regular MS Word documents. 
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EDITING SPECIFICATIONS 
This chapter describes all of the operations you may need to perform in order to create or 
modify a specification with PASAT. 

Changing Tag and Entity Display 
By default, the PASAT files are displayed in the MS Word window in the Tags Off mode 
(with tags hidden), which makes the specifications look like regular MS Word 
documents. The entities, by default, are displayed as the special characters they represent.  

Showing/Hiding Tags 
PASAT handles all the XML-related operations behind the scenes, so that there is no 
need to see the XML markup (tags) in the normal course of specification editing. If, 
however, you want to display the tags – for example, for diagnostic purposes – PASAT 
lets you do so at any time. 
To toggle between the Tags Off and Tags On modes, select View Tags from the View 
menu. If the tags were hidden, PASAT displays them and vice versa. 
Example of Tags Off 

 

Example of Tags On 

 
Note: When a table is rendered, the tags of the table elements (row, entry, etc.) are 
hidden even if the document is in the Tags On mode. The tags of the table itself (<table> 
and </table>) are shown. For details, refer to the Rendering and Unrendering section. 
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Changing Entity Display Mode 
If, for some reason, you want to display the special character entities embedded in your 
specification as XML codes, you can do that at any time. 
To view either the Symbol and Code for a special character highlight the special 
character in the specification text and then select the View Entities option from the View 
menu. The View Entities option has a toggle function whereby if you select View Entities 
once it will display the code equivalent for the special character symbol and if you select 
it a second time the inserted character symbol is displayed. 
In brief, if the entities were displayed as special characters, PASAT displays them as 
codes and vice versa. 

Using the Specification Map 
The Specification Map is a tree of the specification sections and elements. 

 
Specification Map to the Left of a Specification 

The appearance and functionality of the Specification Map are similar to those of the 
Document Map in regular MS Word documents. You use the Map feature to navigate 
through the specification.  

Showing/Hiding the Map 
To show/hide the Specification Map, select Document Map from the View menu. If the 
map was hidden, PASAT displays it and vice versa.  

Navigating Specifications with the Map 
To expand a collapsed section of the specification tree, click the corresponding node 
(marked with the "+" sign). 
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To collapse an expanded section of the specification tree, click the corresponding node 
(marked with the "-" sign). 
To display a section/element of the specification in the MS Word window, click its title 
in the specification tree. 
To highlight an element in the specification tree, position the cursor within this element 
in the specification. 

Editing Specification Sections 
PASAT enables you to add sections to or delete them from the specification at any time 
during the editing process. 

Note: You cannot delete sections that are defined as required. 

To edit the specification sections: 
1. Select the Edit Sections option from the Tools popup menu. The Edit Specification 

Sections dialog is displayed. Its layout and functionality are identical to those of 
the Create New Specification dialog, which you use while creating a new 
specification. 

 
Edit Specification Sections Window 

2. Check/clear the check boxes adjacent to the section names to add/delete the 
corresponding sections. 
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3. Click the OK button. If you have requested that one or more sections be deleted 
from the specification, a confirmation box is displayed. 

4. To confirm the section deletion request, click the OK button. The dialog closes. 
The sections are added to/deleted from the specification as per your definition. 

Behind the scenes, PASAT adjusts the instance structure accordingly (adds/removes the appropriate tags). 

Managing Selections 
Although this is not visible in the Tags Off mode, the PASAT specification you are 
working on is not a single flow of text, titles, tables, figures, etc., but a collection of XML 
elements – paragraphs, claims, etc. Each element is wrapped in its pair of tags – the start 
tag and the end tag. The outcome of a selection operation you perform depends on 
whether the selection crosses the element boundaries or, in other words, whether it 
includes any tags.  
The possible cases are: 

- The part of the specification you highlighted is entirely within a single element. 

Example:  

<paragraph> Text of the paragraph. </paragraph>  

In this case, only the highlighted part is selected, as it would be in MS Word 
(without any tags). 
 

- The part of the specification you attempt to highlight includes one or both element  
   tags. 

Example:  

<paragraph> Text of the paragraph. </paragraph>  

In this case, the entire element is selected, together with both tags. 

- The part of the specification you attempt to highlight includes the end tag of one  
   element and the start tag of the other element or, in the other words, crosses the  
   element boundary. 

Example:  

<paragraph> Text of the paragraph. </paragraph> <paragraph> Text of another 
paragraph. </paragraph> 
In this case, both elements are selected, together with their start and end tags. 

Note: When a numbered element (a paragraph or a claim) is selected together with its 
tags, the number of the element appears highlighted.  
You can select a numbered element, together with its start and end tags, by double-
clicking its number. 
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Note: In the Tags Off mode, to select a non-numbered element together with its tags, 
extend the selection slightly beyond visual boundary of the element. 
In the Tags Off mode, to select a formatted section (Italic, Superscript or Subscript) 
together with its tags, position the cursor either immediately before the first character of 
the section or immediately after the last character of the section and press the Shift+Left 
Arrow or Shift+Right Arrow combination on the keyboard. 

Managing Paragraphs 
PASAT supports the following paragraph management operations: 

- Addition  

- Splitting 

- Pasting Paragraphs (described in section 5.8.5) 

- Deletion 

- Renumbering 

Adding Paragraphs 
To add a new paragraph to the specification: 

1. Position the cursor at the required location in the corresponding section. 
2. Do one of the following: 

- Select Paragraph from the Insert dropdown list, or 
- Click the Insert New Paragraph option in the Office Assistant callout. 
 

A new (empty) paragraph appears at the specified location, along with a pair of brackets 
for the paragraph number ([]). The numbers are filled out by the Renumber Paragraph 
operation (refer to the Renumbering Paragraphs section for details). 
Behind the scenes, PASAT 

- Generates a unique ID for the new paragraph 
- Inserts the new paragraph element at the specified location 
- Positions the cursor between the start and end tags of the new paragraph element 
   (<paragraph>|</paragraph>)  

You can start keying in the paragraph text. 

Splitting Paragraphs 
To split a paragraph into two separate paragraphs: 

1. Position the cursor at the required split position within the paragraph. 
2. Press Enter on the keyboard. 

The paragraph splits into two paragraphs: 
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- The one from the start of the original paragraph to the cursor position retains the  
   original element number  
 
- The one from the cursor position to the end of the original paragraph becomes a new  
   element and receives a separate number. This new number does not appear until the 
   Renumber Paragraphs operation is performed. 

 
Example 
Before pressing Enter: 

 
After pressing Enter: 

 
Behind the scenes, PASAT  

- Wraps the content of the new paragraph element (from the cursor position to the end of the original 
   element) in a new pair of tags 
- Generates a unique ID for the new element  

Notes: PASAT does not renumber paragraphs automatically after the split. Therefore, the 
original and the new paragraph have the same number until you perform the Renumber 
Paragraphs operation. For details, refer to the Renumbering Paragraphs section. 
Pressing the Enter key when the cursor is at the very end of a paragraph (between the last 
character and the end tag) creates a new paragraph. 
Pressing the Enter key when the cursor is positioned within a program-listing element 
adds a hard return to the text just as it would in MS Word. No element split occurs. 

Deleting Paragraphs 
To delete a paragraph as a whole: 

1. Double-click the paragraph number to select the paragraph. 
2. Press Delete on the keyboard. 

The selected paragraph is removed from the specification (together with its number), as 
well as from the Specification Map. 
Behind the scenes, PASAT removes the paragraph element from the specification.  

Note: You cannot delete all paragraphs in a section. You may insert your correct 
paragraph and then go back and delete the incorrect paragraph. Or, you may delete the 
section in its entirety and re-enter the text. 
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Renumbering Paragraphs 
As a result of adding, deleting and splitting operations, the paragraph numbers may get 
out of sequence: [0001] comes after [0003], [0012] between [0007] and [0004], etc. 
To renumber paragraphs in a sequential manner, starting from the beginning of the 
specification, select Renumber, and then Paragraphs from the Tools popup menu. 

Managing Claims 
Claims have hierarchical structure. The main element in the hierarchy is the claim itself. 
It is represented by a number and can be referenced from other claims or paragraphs. 
Under the claim, an unlimited number of claim-text elements can be created. These 
elements have no numbers and cannot be referenced. The claim-text elements support up 
to five indentation levels, each of which corresponds to the position in the claim 
hierarchy. 

Example (Two Indentation Levels) 
<claim> 
<claim-text> First indentation level </claim-text> 
<claim-text><claim-text> Second indentation level </claim-text></claim-text> 
</claim> 
PASAT supports the following claim management operations: 

- Addition of claims 

- Pasting claims (described in section 5.8.6) 

- Addition of claim-text elements 

- Indenting claim-text elements  

- Splitting claim-text elements 

- Deletion of claim-text elements 

- Splitting claims 

- Deletion of claims 
- Renumbering claims 
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Adding Claims 
To add a new claim to the specification: 

1. Position the cursor at the required location in the Claims section. 
2. Click the Insert New Claim option in the Office Assistant callout. 

A pair of brackets for the claim number appears at the specified location ([c]). Claim 
numbers are filled out by the Renumber Claims operation (refer to the Renumbering 
Claims section for details). You can start keying in the text of the claim. 
Behind the scenes, PASAT 

- Generates a unique ID for the new claim 
- Inserts the new claim element at the specified location 
- Inserts a new claim-text element within the claim element 
- Positions the cursor between the start and end tag of the new claim-text element (<claim><claim- 
   text>|</claim-text><claim>)  

Adding Claim-text Elements 
To add a new claim-text element under a claim: 

1. Position the cursor at the required location within a claim. 
2. Do one of the following: 

- Select the Claim-text option from the Insert dropdown list, or 

- Click the Insert New Claim-text option in the Office Assistant callout. 

The cursor moves to the next line. 
Behind the scenes, PASAT 

- Inserts the new claim-text element at the specified location  
- Positions the cursor between the element's start and end tags (<claim-text>|<claim-text>)  
 

You can start keying in the text. 

Indenting Claim-text Elements 
In the Tags Off mode, claim-text elements appear as text sections separated by line 
breaks. Each of these sections can be positioned at one of the five available levels of 
indentation.  
To change indentation of a claim-text element: 

1. Position the cursor anywhere within the required element. 

2. Click the Increase Indent  or Decrease Indent button on the toolbar.  
With each click of the toolbar button, indentation of the selected claim-text element 
increases or decreases, respectively. 
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Splitting Claim-text Elements  
To split a claim-text element into two separate sections: 

1. Position the cursor at the required split location within the claim-text element. 
2. Press Enter on the keyboard. 

The claim-text element splits into two elements at the cursor location. They both stay at 
the indentation level of the original element.  
Behind the scenes, PASAT wraps the content of the new element (from the cursor position to the end of 
the original element) in a new pair of tags. 

Deleting Claim-text Elements 
To delete a claim-text element from a claim: 

1. Highlight the claim-text element together with its tags (for details, refer to 
the Managing Selections section). 

2. Press Delete on the keyboard. The selected claim-text element is deleted. 
Behind the scenes, PASAT removes the element's content and tags from the specification. 

Note: You cannot delete all claim-text elements in a section. You may insert your correct 
claim-text and then go back and delete the incorrect claim-text. Or, you may delete the 
section in its entirety and re-enter the text. 

Splitting Claims  
To split a claim into two separate claims: 

1. Position the cursor at the required split location within the claim. 
2. Press Ctrl+Enter on the keyboard. 

The claim splits into two claims at the cursor location:  
- The one from the start of the original claim to the cursor position retains the original 
   element number  
- The one from the cursor position to the end of the original claim becomes a new  
   element and receives a separate number. This new number does not appear until the  
   Renumber Claims operation is performed. 
 

Behind the scenes, PASAT wraps the content of the new element (from the cursor position to the end of 
the original element) in a new pair of tags. 

Deleting Claims 
To delete a claim as a whole: 

1. Double-click the claim number to select the claim. 
2. Press Delete on the keyboard. 
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The selected claim is removed from the specification (together with its number), as well 
as from the Specification Map. 
Behind the scenes, PASAT removes the claim element along with all claim-text elements it contained 
from the specification.  

Note: In accordance with the USPTO DTD, the last claim in a section cannot be deleted. 
You can, however, delete its content. 

Renumbering Claims 
As a result of adding, deleting and splitting operations, the claim numbers may get out of 
sequence: [c1] comes after [c3], [c12] between [c7] and [c4], etc. 
To renumber claims in a sequential manner, starting from the beginning of the 
specification, select the Renumber option from the Tools menu, and then select the 
Claims option from the sub-menu that appears. 

Managing Claim Dependencies 
PASAT supports the following management operations for the claim dependencies: 

- Creating claim dependency references 

- Redefining the reference targets 

- Deletion of claim dependency references 

Creating Claim Dependency References 
To create a reference to a claim dependency from within a claim-text element: 

1. Do one of the following: 
- Position the cursor at a location from which you want to reference a claim 
   dependency. 
 
- Select a section of text (without tags)  

2. Do one of the following: 
- Select the Dependent-claim-reference option from the Insert dropdown list, or 
 
- Click the Insert Dependent Claim Reference option in the Office Assistant  
   callout. 

 
The Modify Dependent Claim Reference Target dialog is displayed. 

 

EFS Authoring Manual: PASAT v4.0 Editing Specifications 35



  
 
 

 
Modify Dependent Claim Reference Target Window 

This dialog lists all the claims currently in the specification (except for the one the cursor 
is positioned in): ID, number and the beginning of the text. 

3. Highlight the required claim on the list and click the OK button. 
Behind the scenes, PASAT  

- If text was selected, wraps this text in the dependent-claim-reference pair of tags; if no text was 
   selected, inserts a dependent-claim-reference element at the specified location  
- Positions the cursor inside the element, between its start and end tags (<dependent-claim- 
    reference>|</dependent-claim-reference>) 
-  Sets the value of the element's "target" attribute to the ID you have referenced 

 
4. Optionally, type relevant text (such as "Refer to..."). The text you type inside the 

dependent-claim-reference element is underlined in blue. 

When the specification is viewed as an XML instance, the references are 
rendered as hyperlinks. 

Redefining Reference Targets 
To re-define the target of a claim dependency reference: 

1. Position the cursor anywhere within the text of the required claim dependency 
reference (underlined in blue). 

2. Click the Edit Dependent Claim Reference option in the Office Assistant 
callout, and the Modify Dependent Claim Reference Target dialog is displayed.  

3. Proceed as described in the Creating Claim Dependency References section.  
Behind the scenes, PASAT changes the value of the "target" attribute of the dependent-claim-reference 
element.  

Deleting Claim Dependency References 
To delete a claim dependency reference: 

1. Select the reference to be deleted (the text underlined in blue together with the 
corresponding tags). 
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2. Press Delete on the keyboard. 
The selected reference is deleted (both the element and the text). 
Behind the scenes, PASAT removes the content and tags of the dependent-claim-reference element from 
the specification. 

Formatting Text 
PASAT supports three formatting options: 

- Italic 

- Superscript 

- Subscript 

The above options work similarly to their counterparts in MS Word: 
- Formats can be applied and removed 
 
- Special characters within the formatted section take on the same format the text has 

 
- When you position the cursor within a formatted section, the corresponding button 
   on the Format toolbar appears depressed  

Applying a Format 
To apply a formatting option: 

1. Do one of the following: 
- Select a section of text you want to format, or 
 
- Position the cursor at a location where you want to type formatted text. 

 
2. Do one of the following: 

- Click the required formatting button on the Format toolbar, or 

- Press the corresponding accelerator key(s) on the keyboard.  

- One of the following happens: 

- If you have selected a section of the text, this section is formatted. 

- If no text was selected, the format applies to the new text as you type it at the 
   cursor location. 
 

Behind the scenes, PASAT 

- If text is selected, wraps the selection in a format element and applies the selected format to it (e.g.,  
  for Italic: <emphasis> the selected text </emphasis>) 
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- If no text is selected, inserts a new format element at the cursor location and positions the cursor  
  between its start and end tags (e. g., for Italic: <emphasis>|</emphasis>) 

Note: You can superimpose format options (e.g., italicize a superscript section). In the 
Tags Off mode, to select a formatted section together with its tags (for adding one more 
format option):  
Position the cursor immediately before the first character of the section and press 
Shift+Right Arrow combination on the keyboard, or position the cursor immediately after 
the last character of the section and press the Shift+Left Arrow combination on the 
keyboard.  

Removing a Format 

You can remove format only from the entire formatted section, not from its 
parts. 

To remove a format: 
1. Position the cursor anywhere within the formatted section. 
2. On the Format toolbar, click the button that appears depressed. 

The format is removed from the selection. 
Behind the scenes, PASAT "unwraps" the formatted section (removes the format start and end tags).  

Note: It might happen that, as a result of the above operation, the format appears to have 
been removed from only part of the section. This would mean that you encountered a 
series of two or more contiguous, similarly formatted sections (e. g., italic: <emphasis> 
Text_1 </emphasis><emphasis> Text_2 </emphasis>). In the Tags Off mode, they look 
like a single formatted section (Text_1Text_2). Position the cursor within the part that 
remains formatted and repeat the operation.  

Copying, Cutting and Pasting 
PASAT supports the following clipboard operations: 

- Copying 

- Cutting 

- Pasting 

- Pasting Paragraphs 

- Pasting Claims 
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Copying 
The Copy operation copies a selection from a specification to the clipboard. If the copied 
selection includes tags, this operation copies markup along with the content. 
To copy a selection to the clipboard: 

1. Select the section to be copied. 
2. Do one of the following: 

- Select the Copy option from the Edit menu, or 

- Click the Copy button on the toolbar, or 

- Press Ctrl+c on the keyboard. 

Cutting 
The Cut operation copies a selection from a specification to the clipboard and deletes it 
from its original location. If the selection includes tags, this operation cuts markup along 
with the content. 
To copy a selection to the clipboard and delete it from its original location: 

1. Select the section to be cut. 
2. Do one of the following: 

- Select the Cut option from the Edit menu, or 

- Click the Cut button on the toolbar, or 

- Press Ctrl+x on the keyboard. 

Pasting 
The Paste operation pastes clipboard content at the cursor position in the specification. 
Content without markup is pasted as plain content. Content that includes markup will be 
pasted as marked-up content. 

PASAT supports replacement of a selection with the clipboard content only if 
neither the selection nor the clipboard content include markup.  

To paste the clipboard content: 
1. Position the cursor at the location where you want the clipboard content to be 

pasted.  
2. Do one of the following: 

- Select Paste from the Edit menu, or 

- Click the Paste button on the Edit toolbar, or 
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- Press Ctrl+V on the keyboard. 

The clipboard content appears at the cursor location in the specification. 

Note: If the clipboard contained characters (symbols) not supported by PASAT, in the 
specification they are replaced by the Unknown Symbol signs. You can delete the signs 
and/or replace them with the PASAT-supported symbols. For the replacement procedure, 
refer to the Replacing Unknown Symbols section. 

Errors in Pasting into PASAT 

Content Loss in Paste to PASAT 
Occasionally you may lose content when copying from a source document and pasting 
into PASAT. The following situations are known to cause this error: 
Non-breaking spaces and hyphens: 
In source documents with non-breaking spaces and hyphens both from MS Word and 
WordPerfect, PASAT losses the text string after the non-breaking character. 

 
Microsoft Word Document Displaying Spaces and a Non-breaking Space 

The degree-like symbol between "brown" and "fox" represents a non-breaking space (the 
non-breaking space is inserted by key stroking CTRL + SHIFT + SPACE) and when the 
sentence is edited those two words will always appear on a single line and will never be 
word wrapped. When symbol is pasted into PASAT this is the outcome: 

The lazy brown jumps over the log 
The text string of "fox" is lost.  
A non-breaking hyphen (CTRL + HYPHEN) pasted into PASAT is displayed as an 
unknown symbol. 
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Smart Quotes, Aprostophes, Fractions, & Double Hyphens  
Source documents (both MS Word & WordPerfect) that contain smart quotes lose the 
quotes upon a paste to PASAT and apostrophes are translated to quotation marks. Smart 
quotes are quotation marks that are curled in an open and closed manner and are different 
that "unidirectional" quotes. In MS Word you turn on smart quotes by choosing 
AutoCorrect from the Tools menu. 

 
Microsoft Word’s AutoCorrect Window 

This AutoCorrect feature causes other translation issues, which are summarized below: 

-    Smart Quotes get lost therefore if you have  
"Title of a Book" it will translate to: 
Title of a Book 

-    With Smart Quotes on Apostrophes translates to straight quotes, for example: 
if you have Bill's bike it translate to  
Bill"s bike  

-  With the option that Double Hyphens (--) becomes a single bar –this does not 
      translate any hyphens at all. 
 

This behavior is a little different between Word 97 and 2000 (in Word 2000 the smart 
quotes translate. 
To manually search out the special characters before copying and pasting into PASAT: 

1. In the source document in Word go to Edit from the toolbar and select Replace. 
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2. In the Find & Replace window, select the Replace tab 
3. Click on the “more” button to show more options by which to search 

 
Microsoft Word’s Find and Replace Window - Compact 

4. On the next screen click on the “special” button to show special characters to 
search for 

 
Microsoft Word’s Find and Replace Window - Expanded with Special Pop-up Window 

5. To search and replace “nonbreaking spaces”, select the “nonbreaking spaces” from 
the “special” button and this selection will be placed in the “find what” section. In 
the “replace with” selection, type a “space” by just hitting the space bar one time 

6. Once the “find” and “replace” fields have been filled in, select “replace all”. You 
should receive a message that says the following: 

 
Microsoft Word’s Replacements Window 
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7. You may repeat these steps for each special character that may cause lost content 
when pasting into PASAT. 

Translation errors when copying and pasting from WordPerfect into PASAT 
You copy from a WordPerfect 9 document into PASAT. PASAT deleted every text string 
following a soft return in the document. You are using Windows NT and Word 2000. 
Following every hard return, a space was deleted so that the last text string on one line 
ran into the text string on the next line. All soft hyphens in the WordPerfect document 
were translated as underscores. The degree symbol translated as a capital Epsilon. When 
the WordPerfect document was opened in Word and copied and pasted in to PASAT, the 
text string following a soft hyphen was deleted. When the WordPerfect document was 
saved as a *.doc file and opened in Word better translation was obtained, however the 
degree symbol was still translated as an Epsilon and the run-on text strings still appeared. 
The degree symbol problem can be overcome if the entire document is changed to Arial 
font. 

Emphasis Rendering in PASAT 
In the stylesheet all emphasis tags render as italics. It should be further noted that PASAT 
automatically upon paste takes underline, bold and italics and applies emphasis tags.  

 
Specification Document Showing Text in the Emphasis Tag in Italic 

Pasting Paragraphs 
The Paste Paragraphs operation pastes text sections as paragraphs.  

Note: This operation is enabled if paragraphs are allowed at the current cursor position. 
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While pasting text copied from a non-structured document (e. g., from a regular MS 
Word file), all text formatting (Bold, Italics, etc.) is lost. 

To paste the clipboard content as multiple paragraphs: 
1. Copy a section of text to the clipboard. 
2. Position the cursor at the location where you want the clipboard content to be 

pasted. 
3. Select the Paste Paragraph(s) option from the Edit menu. 

The text from the clipboard is pasted at the specified location.  

Pasting Claims 
The Paste Claims operation pastes text sections as multiple claims. The text is split into 
claims based on hard returns. 

Note: This operation is enabled only in the Claims section. 

To paste the clipboard content as multiple claims: 
1. Copy a section of text to the clipboard. 
2. Position the cursor at the location where you want the clipboard content to be 

pasted.  
3. Select Paste Claim(s) option from the Edit menu. The text from the clipboard is 

pasted at the specified location as multiple claims. The text is split into claims at 
hard returns.  

4. Renumber the new claims by selecting Renumber and then Claims from the 
Tools menu. 

Examples 
Clipboard content (copied from an MS Word document): 

 
Pasted using the Paste Claims option and renumbered: 
[c2] A method according to claim 1 wherein the vinyl strap is 120" to 240" 
and can be measured and cut into shorter, customized-length strips. 
[c3]  A method according to claim 1 wherein the vinyl strap is transparent. 
[c4]  A method according to claim 2 wherein the vinyl strap is transparent.  
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Reversing Operations 
The Undo operation in PASAT can reverse the following operations (up to 6): 

- Insertion of text 

- Deletion of content 

- Cutting and Pasting (except for Paste Paragraphs and Paste Claims) 

- Formatting text 

- Splitting paragraphs 

To reverse an operation, do one of the following: 
- Select the Undo option from the Edit menu, or 

- Press Ctrl+z on the keyboard, and the last operation on the Undo list is reversed.  

Managing Complex Work Units 
PASAT recognizes the following Complex Work Units (CWU): 

- Table - CWU (an MS Word table or a scanned table in a .tiff file ) 

- Math - CWU (a math formula in a .tiff file, inserted inline) 

- Chemistry - CWU (a chemical formula in a .tiff file, inserted inline) 

PASAT supports the following CWU management operations: 
- Insertion 

- Deletion  

Inserting Math - CWU and Chemistry - CWU 
To insert a Math - CWU or Chemistry - CWU: 

1. Position the cursor in the required location.  
2. Do one of the following: 

- Select the Math - CWU or Chemistry - CWU option from the Insert dropdown  
   list, or 
 
- Click the corresponding button in the Office Assistant callout, and the  
    Windows File Open dialog is displayed with a default extension .tif. 
 

3. Select the required file and click the OK button, and the selected graphic 
appears at the specified location. 

Behind the scenes, PASAT wraps the inserted CWU in the appropriate start and end tags (e. g., for Math: 
<math-CWU> graphic </math-CWU>). 
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Inserting Table - CWU 
To insert a Table - CWU: 

1. Position the cursor at the required location. 
2. Do one of the following: 

- Select Table - CWU from the Insert dropdown list, or 

- Click the corresponding button in the Office Assistant callout, or 

- Select the Insert Table option from the Table menu, and the New Table Size 
   dialog is displayed. 

 
New Table Size Window 

3. Do one of the following: 
a. To insert an MS Word table, type the required number of rows and columns 

in the corresponding fields and click the OK button. 
b. If you have inserted an MS Word table, behind the scenes, PASAT inserts the 

required XML table elements at the specified position. E.g., for a table that has 
two rows and two columns the XML structure looks like:  
<Table-cwu><Table><TGroup><TBody><Row><Entry></Entry> 
<Entry></Entry></Row> 
<Row><Entry></Entry><Entry></Entry></Row></TBody> 
</TGroup></Table> 
</Table-cwu> 

OR 
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a. To insert a scanned table in a .tiff file, click the Browse button, select the file, 
and click the OK button. The new table is inserted at the specified location. 

b. If you have inserted a scanned table as a .tiff file, behind the scenes, PASAT 
wraps the inserted CWU in the appropriate start and end tags: <Table-cwu> 
graphic </Table-cwu>.  

Note: Tiff images must be done a page at a time and columns might become skewed due 
to scanning or printing. 

Deleting Complex Work Units 
To delete a CWU: 

1. Double-click the required CWU element in the specification.  
2. Press Delete on the keyboard. The selected CWU is deleted. 

Behind the scenes, PASAT removes the element's content and tags from the specification.  

Managing Tables 

This section does not pertain to the scanned tables inserted as .tiff files. 

PASAT supports the following table management operations: 
- Inserting Tables 

- Rendering/Unrendering Tables 

- Pasting Tables 

- Inserting Rows 

- Inserting Columns 

- Resizing Columns 

- Deleting Rows 

- Deleting Columns 

- Merging Cells 

- Splitting Cells 

- Deleting Tables 

You perform most of the table management operations the way you would perform them 
in MS Word.  
Behind the scenes, PASAT inserts or deletes the appropriate XML elements so that the validity of the 
table structure is always preserved. 
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Row/column insertion and deletion operations are enabled only in rendered 
tables. 

Inserting Tables 
To insert a table, follow the steps described in the Inserting CWU - Table section.  

Rendering/Unrendering Tables 
Rendered tables are displayed as regular MS Word tables. Unrendered tables are 
displayed as groups of XML table elements. You don't have to work with or even see the 
tables unrendered in the normal course of the specification editing. If, however, you want 
to unrender a table – for example, for diagnostic purposes – you can do so at any time.  
To toggle between the rendered and unrendered display of a table: 

1. Position the cursor anywhere within the table. 
2. Select Convert Table from the Table menu. If the specified table was rendered, it 

becomes unrendered and vice versa.  

Pasting Non-Structured Tables 
PASAT enables you to paste non-structured tables (copied from regular MS Word 
documents) into your specification. While pasting, PASAT converts the regular MS 
Word table to a valid XML table (inserts all necessary tags). 
To paste a non-structured table into specification: 

1. Copy the required table from a regular MS Word document. 
2. Position the cursor at the required insertion position. 
3. Select the Paste Table option from the Edit menu. The table from the clipboard is 

pasted at the specified position. 
Behind the scenes, PASAT inserts all the necessary tags at the specified location and copies the table 
contents to the appropriate elements.  

Note: Pasting Tables functionality does not allow for nesting of formatting tags such as 
x<superscript>5<emphasis>i</emphasis></superscript> which is x5i . 
In some instances, crashes occur when trying to paste tables. 

Inserting Rows  
To insert a row into a table: 

1. Position the cursor in a row adjacent to where you want the new row to appear. 
2. From the Table menu, select the Insert option, and then select Row Above or 

Row below, depending on where you want the new row to be added. 
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Inserting Columns 
To insert a column into a table: 

1. Position the cursor in a column adjacent to where you want the new column to 
appear. 

2. From the Table menu, select the Insert option, and then select Column to the 
Right or Column to the Left, depending on where you want the new column to 
be added. 

Resizing Columns 
To resize a column: 

1. Highlight the column to be resized. 
2. Move the column separator in the required direction with the cursor. 

Deleting Rows 
To delete a row: 

1. Position the cursor in the row to be deleted. 
2. From the Table menu, select Delete, and then select Delete Row. 

You can delete only one row at a time. 

Deleting Columns 
To delete a column: 

1. Position the cursor in the column to be deleted. 
2. From the Table menu, select Delete, and then select Delete Column.  

Merging Cells 
To merge two table cells into one: 

1. Highlight the cells to be merged. 
2. From the Table menu, select the Merge Cells option. The selected cells are 

merged into one. 
Behind the scenes, PASAT unites the entry elements that correspond to the selected cells into a single 
entry element.  

Splitting Cells 
To split a cell: 

1. Position the cursor in the cell to be split. 
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Note: PASAT splits only those cells that were previously merged. 

2. From the Table menu, select the Split Cell option. The selected cell is split into 
two original cells. 

Behind the scenes, PASAT splits the entry element that corresponds to the selected cell into two original 
entry elements.  

You can delete only one column at a time. 

Deleting Tables  
To delete a table: 

1. Double-click within the table. 
2. Press the Delete button on the keyboard. 

Managing Figures 
PASAT supports the following operations with figures: 

- Addition 

- Reordering 

- Removal 

Note: The only allowed format for the figures is .tiff (not compressed). 
Once inserted, figures cannot be resized.  
The MS Word Graphic toolbox is disabled. 

You perform all figure management operations in the Figures dialog. 

Displaying the Figures Dialog 
To display the dialog, do one of the following: 

1. Click the Insert Figures option in the Office Assistant callout, or 
2. Select the Picture option from the Insert popup menu. The Figures dialog is 

displayed. 
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Figures Window 

The dialog layout is:  
The right-hand pane displays the figures that are already in the specification (if any), 
in the order in which they appear in the Figures section  
 
The Source field (across the top) shows the path and name of the source file for the 
figure selected in the right-hand section 

 
The left-hand pane offers a series of buttons each of which performs the 
corresponding operation on the figure selected in the right-hand section 

 
The OK/Cancel group of buttons in the lower left-hand corner is used to accept/reject 
the changes you have made to the Figures section and to close the dialog 

Adding Figures 
To add a figure: 

1. If there are figures displayed on the right-hand pane of the Figures dialog, 
highlight the figure adjacent to which you want to insert the new figure. 

2. Click the Add Below or Add Above button. The Image File dialog is displayed 
with a default extension .tif|tiff. 
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3. Select the required file and click the OK button. The selected graphic appears at 
the specified location on the right-hand pane of the Figures dialog. The Figures 
dialog closes. The new figure is inserted at the specified location in the Figures 
section of the specification.  

Behind the scenes, PASAT  

- Creates a new figure element at the specified location and generates a unique ID for it 

- Within the figure element, creates an artwork element and sets its "target" attribute to the selected  
  .tiff file (<figure><artwork> graphic </artwork></figure>). 

Reordering Figures 
To change the order in which the figures appear in the Figures section: 

1. Highlight the figure to be moved on the right-hand pane of the Figures dialog. 
2. Click the Move Up or Move Down button. Each click moves the highlighted 

figure one position up or down on the list, respectively. 
3. When satisfied with the new order, click the OK button. The Figures dialog 

closes. The figures in the Figures section appear in the new order. 

Removing Figures 
To remove a figure: 

1. Highlight the figure to be removed on the right-hand pane of the Figures dialog. 
2. Click the Remove button. The figure is removed from the right-hand pane. 
3. Click the OK button. The Figure dialog closes. The selected figure is removed 

from the Figures section of the specification. 
Behind the scenes, PASAT removes the corresponding figure and artwork elements from the specification 
and from the Specification Map. 
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Managing Special Characters 

 
Symbol Manager Window with Dropdown List 

PASAT supports special characters defined by the ISO standard No 8859-1 (HTML 4.0 
named character entities). It contains the following character sets, accessible from the 
dropdown menu in the Character Set field of the Symbol Manager window: 

- HTMLlat1 
- HTMLspecial 
- HTMLsymbol 
- Basic Greek 

PASAT also enables the use of custom characters, which should be drawn or scanned and 
saved as .tif files. 
The special character management activities are: 

- Insertion 
- Search for and replacement of the unknown symbols 
- Deletion 

Inserting HTML Characters 
To insert an HTML character: 

1. Position the cursor at the insertion point. 
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2. Select the Symbol option from the Insert menu. The Symbol dialog is displayed. 

 
Symbol Manager Window (Similar to Microsoft Word’s Symbol Window) 

3. Select the required entity set from the Entity Set dropdown list. The required set is 
displayed in the dialog. 

4. Highlight the required character in the set. 
5. Click the Insert button. 

The selected character is inserted at the cursor location as an entity. 

Inserting Custom Characters 
To insert a custom character: 

1. Position the cursor at the insertion point. 
2. Select the Symbol option from the Insert menu. 

The Symbol dialog is displayed. 
3. Click the Custom Character tab. 

The Custom Character page is displayed. 
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Symbol Manager Window - Custom Character tab 

4. Click the Add button. 
The Browse for Graphic dialog is displayed. 

 
Browse for Graphic Window (Standard File Open Window) 

5. Select the .tif file you want to use as a custom character and click the Open 
button. 

The image contained in the selected file is displayed on the central panel of the Custom 
Character page. 
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6. Highlight the image. 
The path and name of the corresponding file appear in the Source field. 

7. Click the Insert button. 
The selected image is inserted at the cursor location as a custom character. 
Behind the scenes, PASAT encloses the inserted image in a pair of appropriate tags. 

Replacing Unknown Symbols 
As a result of pasting sections copied from non-PASAT documents, your specification 
may contain unknown symbols, marked in the text by the Unknown Symbol sign. 
To replace the unknown symbols with the appropriate special characters: 

1. Display the Insert Symbol dialog. 
2. Click the Next Unknown button. 

The first Unknown Symbol sign in the specification is highlighted. 
3. Select the special character or specify the custom character to replace the unknown 

symbol. For procedure, refer to the Inserting HTML Characters and the 
Inserting Custom Characters section, respectively. 

4. Repeat steps 2 and 3 for each unknown symbol. 

Copied the double arrow symbol from a Word 97 doc and pasted into PASAT. 
PASAT will indicate if an unknown symbol was found if there is a mistranslation of the 
copied double arrow symbol and prompt you to use symbol manager to insert the double 
arrow symbol using the PASAT Insert Symbol function. Click on the first occurrence of 
unknown symbol. Go to the tab insert symbol and select the required symbol, then Click 
on insert. OR, select the insert custom character tab, if symbol required is not displayed. 
Click on the Add button, find tiff file, highlight the tiff thumbnail, and clicked on Insert.  

Deleting Special Characters 
To delete a special character: 

1. Highlight the required character in the specification. 
2. Press Delete on the keyboard. The selected special character is deleted from the 

specification. 

Entering Biological Deposit Data 
The Biological Deposit Data is an optional element of the Detailed Description of the 
Invention section. 
To enter the Biological Deposit Data: 

1. Position the cursor anywhere in the Detailed Description title. 
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2. Select the Insert Biological Deposit Data option from the Office Assistant 
callout. 

The Biological Deposit Data title appears in the specification. 
3. Select the Insert Biological Deposit option from the Office Assistant callout. 

The Enter Biological Deposit Data dialog is displayed. 

 
Enter Biological Deposit Data Window 

4. Fill out the dialog fields. 
5. Click the OK button. 

The dialog closes. The data you have entered appears in the specification under the 
Biological Deposit Data title in a predefined layout.  
Behind the scenes, PASAT builds a markup structure as defined by the content model of the Biological 
Deposit Data element.  

Spell-Checking 
As in MS Word, you can perform spell-checking in two modes: Real-time and Batch. In 
both modes, PASAT uses all custom dictionaries selected in the MS Word Options 
dialog. 
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Real-Time Spell-Checking 
As in MS Word documents, the misspelled words in the specification are underlined in 
red. 
To correct the spelling of an underlined word: 

1. Left-click anywhere in the underlined word. 
2. Right-click anywhere in the underlined word. 
3. Select the required spelling option from the popup list that appears. The 

misspelled word is replaced with the word you chose from the list. 

Batch Mode Spell-Checking 
To spell-check the entire specification: 

1. Select the Check Spelling option from the Tools menu. The Content Spelling 
dialog is displayed. 

 
Content Spelling Window 

The layout and functionality of this dialog are very similar to those of the MS Word 
Spelling and Grammar dialog: 

- The upper pane displays the misspelled word highlighted in the specification text 

- The lower pane displays the spelling suggestions for this word 

- The buttons in the right-hand section enable you to change or ignore the highlighted 
   occurrence of the misspelled word or of all the occurrences of this word in the 
   specification 
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Note: The PASAT spell-checker deals only with the spelling of the individual words. It 
does not check the grammar structures. 
The AutoCorrect, Options and Undo buttons are disabled. 

2. Proceed with the spell-checking as you would in a regular MS Word document. 
Behind the scenes, PASAT 

- Separates the specification content from the markup so that only the content spelling is checked 

- Updates the XML instance in accordance with the changes you make in the MS Word window 

Finding and Replacing Content 
As well as MS Word, PASAT enables you to search for words and phrases and, 
optionally, automatically replace them with other words and phrases. The "specialty" of 
PASAT is that its Search and Replace capabilities pertain only to the content of the 
displayed instance, not to the markup it may include. 

Finding Words and Phrases 
To find a word or a phrase: 

1. Select the Find option from the Edit menu. 
The Content Find and Replace dialog is displayed. 

 
Content Find and Replace Window 

2. Proceed with the Find operation as you would in a regular MS Word document. 
Behind the scenes, PASAT separates the specification content from the markup so that only the content is 
searched for the required words/phrases. 

Replacing Words and Phrases 
To automatically replace a word or a phrase with another word/phrase: 

1. Select the Replace option from the Edit menu. 
The Replace page of the Content Find and Replace dialog is displayed. 
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Content Find and Replace Window 

2. Proceed with the Replace operation as you would in a regular MS Word 
document.  

Behind the scenes, PASAT 

- Separates the specification content from the markup so that only the content undergoes word/phrase 
   replacement 
 
- Updates the XML instance in accordance with the changes you make 
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VALIDATING AND PREVIEWING SPECIFICATIONS 
Before you export a specification to an .xml file, it is strongly recommended that you 
validate its structure and correct all errors revealed by the validation process. You may 
also want to preview the specification in the Internet browser window, to get a clear idea 
of how it is going to look as a rendered XML instance. 

Validating Specifications 
To validate a specification: 

1. Select the Validate Instance option from the Tools menu. 
PASAT starts the validation process from the beginning of the document. When it 
encounters a structural error, this error is displayed in a message box. 

 
2. Click the OK button. The section that caused the error is highlighted in the 

specification. 
3. Correct the highlighted error. 
4. Repeat steps 1 through 3 until the "Instance is Valid" message is displayed. Your 

specification is now XML-valid and is ready to be exported as an XML instance. 

Previewing Specifications 
To preview a specification in an Internet browser: 

1. Select the Preview in Browser option from the File menu. Your default Internet 
browser is launched. The specification is displayed in the browser window as an 
XML instance. 

2. Check the appearance of your specification.  
3. To return to the specification in PASAT, close the browser window.  

PASAT, Print Preview of IE 5.5 Does Not Display S4W Text 
In previewing in the browser of s4w file content may not be viewable in the Print 
Preview function of IE 5.5. The content is in the XML and shows in the browser but does 
not view in Print Preview display. External Document will show screen shots and provide 
files of this arrangement. When the identical content that gets lost in Print Preview is 
copied and pasted to another location in PASAT – content is not lost. 
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PASAT Error in XML Specification File  
PASAT does not always write the right dimensions for the specification XML file. 
Example of problem that may occur : 

<artwork source="artwork0" height="11" 

width="0"/></figure></figures></specification-block></specification> 

The width="0" is wrong. It shouldn't be 0. 
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SAVING AND EXPORTING SPECIFICATIONS 
The Export XML Specification operation saves specifications in the XML format for 
submission to USPTO. 
The Save Specification operation saves specifications in the PASAT format (.s4w and 
.s4t). Note that it does not generate the .xml file required by the USPTO. There are two 
main reasons for storing a specification as .s4w and .s4t couple as long as you keep 
working on it: 

- An XML-invalid .s4w file can be loaded for further editing in PASAT while an 
invalid XML instance cannot be imported 
 
- Loading an .s4w file is a much faster process than importing an .xml file. 

Saving Specifications 
To save a specification: 

1. Do one of the following: 
- Select Save Specification option from the File menu, or 

- Click the Save Specification button on the toolbar. 

If this is the first time you are saving the specification, the Save Specification dialog is 
displayed. 
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Save Specification Window 

2. In the dialog, specify the path and the name for the .s4w file. 
3. Click the Save button. 

Behind the scenes, PASAT saves the information about the structure of the Specification, its DTD 
reference and formatting template in a separate file with extension .s4t. 

The specification is saved at the specified location with the specified name in two files: 
<name>.s4w and <name>.s4t.  

Note: Specifications are not validated on Save. 
Each consecutive Save Specification operation updates both the .s4w and .s4t files. 
Always keep .s4w files and the corresponding .s4t files in the same directory 
Do not open .s4w and .s4t files in any editor other than PASAT. This will corrupt the 
specification.  

Exporting Specifications 
To export a specification: 

1. Do one of the following: 
- Select the Export XML Specification option from the File menu, or 

- Click the Export XML Specification button on the toolbar. The Export  
   Specification dialog is displayed. 

 
Export XML Specification Window 
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2. In the dialog, specify the path and the name for the .xml file you want to export 
the specification to.  

3. Click the Save button. 
If the specification is valid (conforms to the USPTO DTD), it is saved at the specified 
location with the specified name as an XML instance (.xml file), ready for submission to 
the USPTO.  
If the specification is invalid, the appropriate warning is displayed. 
Behind the scenes, PASAT 

- Validates the specification against the USPTO DTD 

- At the beginning of the exported instance, generates processing instructions that reference the 
   USPTO DTD (Public ID and System ID) and the XSL 
 
- Rebuilds graphic references 
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GLOSSARY 
Content  The part of an XML instance that excludes the 

markup (text, graphics, etc.). 
CWU (Complex Work 
Unit) 

An inline Math or Chemistry formula (.tiff file), or a 
table. 

DTD (Document Type 
Definition) 

An ASCII file that expresses the logical structure 
(valid tags, attributes for those tags, and the 
relationships the tags have to each other) for a 
particular type of XML document. 

Element  A structural component of an XML instance; consists 
of a start tag, content (optional), child elements 
(optional) and an end tag. 

Formatting Template A set of rules that define how an XML instance is 
represented with the use of the MS Word styles. 

Graphic Reference An element that contains the path and name of an 
external graphic file as an attribute. 

Instance  In XML, a document containing markup and 
(optionally) content. 

ID  A unique identifier of an element. It is used to locate 
the element in the instance, define it as a reference 
target, etc. 

Number A unique number generated by PASAT for every 
paragraph and claim in an instance; numbers are 
always visible in the MS Word window. 

Markup  Declarations and tags that describe the structure of an 
XML instance. In PASAT, structure is managed 
completely separately from content, so that markup 
does not have to be explicitly visible. When a PASAT 
document is exported to an XML instance, the 
structure is merged with the content. 

Special Characters HTML 4.0 named character entities, as defined by the 
ISO standard No 8859-1. 

Structure  The organizational form that determines which 
content objects are permitted at any point in a 
document. 

<Structure> Validation A process that determines if the markup grammar and 
syntax of an instance conform to the specified DTD
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syntax of an instance conform to the specified DTD. 
Table  In PASAT, a CALS Exchange Model XML table (a 

group of table elements). When rendered, appears in 
the specification as a regular MS Word table. 

Tag  A descriptive markup unit, which consists of an open 
delimiter (usually “<”), a generic identifier (for 
example, “title”), and a close delimiter (usually “>”). 
The tag, in this case, is <title>. 

XSL  Extensible Stylesheet Language. The XSL file used 
by PASAT contains a set of rules that define how an 
XML instance is represented in an Internet browser. 

XML  A markup language derived from SGML. XML was 
designed to be easy to implement, and to create 
interoperability between SGML and HTML. 

.s4t <file> One of the two files in which PASAT saves each 
instance. Contains the structural information about 
the instance (markup, DTD reference, etc.). 

.s4w <file> One of the two files in which PASAT saves each 
instance. Contains the content of the instance, 
separated from the markup. 
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APPENDIX A: SECTIONS AND CONTENT MODELS 

Title of Invention (Required) 
Contains plain text. May contain italic, superscript and subscript sections. 

 

Copyright Statement (Optional) 
Contains a heading and one or more copyright elements, each of which can contain plain 
text only. 

 

Cross-reference to Related Applications (Optional) 
Contains a heading and one or more continuity statement elements, each of which can 
contain plain text only. 
<Cross-reference-to-related-applications> This element refers to the section of the 
specification describing any related applications, including application for which priority 
under 35 USC 119(e), 120, or 371 is being sought; MPEP 608.01(a), 201.11, 37 CFR 
1.77, 1.78. This section of the specification document is not numbered as a paragraph by 
the authoring tool since it is considered a separate section. 
Continuity statement is a string of continuity data, which is composed of text 
corresponding to the type of application you are submitting, the status of the application 
cited, filing date and document number. The continuity data entered in the application 
data sheet is automatically transferred into USPTO databases as needed for prosecution 
of the patent application. 
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Federal Research Statement (Optional) 
Contains a heading and one or more federal research statement paragraphs, each of which 
must contain a grant number, a contract number and a US agency number. These child 
elements can contain plain text only. 

 

Compact Disc Appendix (Optional) 

 
Insert Object Reference window 

Contains a heading and one or more object references, each of which must contain an 
object ID, object description and object content element. These child elements can 
contain plain text only. 
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Background of Invention (Optional) 
Contains a heading and one or more Sections or paragraphs. Sections must contain a 
heading and one or more paragraphs. 

 

Summary of Invention (Optional) 
Contains a heading and one or more paragraphs. 

 

Brief Description of Drawings (Optional) 
Contains a heading and one or more paragraphs. 

 

Brief Description of Sequences (Optional) 
Contains a heading and one or more paragraphs. 

 

Detailed Description (Required) 
Contains a heading and one or more Sections or paragraphs. Sections must contain a 
heading and one or more paragraphs. 

 

Program Listing Deposit (Optional) 
Contains a heading and one program listing only. 
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Claims (Required) 
Contains a heading and one or more claim items. Claim items contain one or more claim-
text items, which may be indented (nested). 

 

Abstract of Disclosure (Required) 
Contains a heading followed by one paragraph only. 

 

Figures (Optional) 
Contains a heading and one or more figure items. 

 

Paragraph 
The main embodiment for text. Can contain: 

- Plain text 
- List 
- Emphasis 

- Subscript 
- CWU  

- Cross-reference 
- Superscript 
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Claim-Text 
May contain the same information as a paragraph except it does not allow cross- 
references and allows a markush-group element. 
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APPENDIX B: ERROR MESSAGES 

Installation Errors 

Objects Missing in PASAT Tool Launch 
If you receive the following errors while attempting to launch PASAT, you will need to 
download and install PASAT from the EFS website at www.uspto.gov. This version of 
PASAT will replace what you’ve installed from the EFS CD-ROM. 

 

 
To begin this process there are other components that you must have before it will work 
successfully on your workstation. Check each section below to set up your workstation 
properly 

Workstation Operating System 
In some instances, updates to your registry settings may be necessary. To determine if 
this is necessary, open a Word document and go to Tools/Templates & Add-ins. If both 
the efs application.dot and the s4TEXT_Template01.dot are there, then you will need to 
make a change to your privileges in your registry. If the s4TEXT_Template01 is missing, 
you must find someone with administrative privileges and have them sign on to your 
workstation to change registry settings. 

To make changes to the registry settings: 

1. Click the Start button at the lower left corner. 

2. Select Run... from the pop up list. 

3. Type regedit in the Open field of the Run window and click OK. 

4. Double click on HKEY_LOCAL_MACHINE from the Registry Editor window. 
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5. Double click on SOFTWARE under the HKEY_LOCAL_MACHINE tree and on 

the i4i under the SOFTWARE branch to expand the tree structure. 

 
6. Click Security from the menu bar and select Permissions. 
7. Click on the empty square to check Replace Permission on Existing Subkeys at 

the top of the Registry Key Permission window. 
8. Click on Name: Everyone to highlight it. 
9. Click on the drop down arrow in the Type of Access field and select Full Control 

from the drop down list. 
10. Select the check box for Replace Permission with Existing Subkeys. A check 

mark will appear (see figure below). 
11. Click on OK button within the Registry Key Permissions window. 
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12. Click Yes within the Windows NT window, which ask, “Do you want to replace 

the permission on all existing subkeys within i4i?” 
13. Click on the “X” at the upper right-hand corner to close the Registry Editor 

window. 
14. Reboot your machine and attempt to launch PASAT again. 

Document Managing Software 
If you have any other templates or macros installed on your workstation, they could 
interfere with PASAT correctly updating the registry. To verify that the essential 
templates for PASAT are there: 

1. Open a Word document 
2. Go to Tools/Templates & Add-Ins 
3. The essential templates for PASAT to load correctly are: 

- efs application.dot 
- s4TEXT_Template01.dot 
 

4. If these 2 files are in the list, select only those 2 files. Make sure that any others in 
the list are deselected (and no check mark appears in the box to the left.) 

5. Click OK to close the window. 
6. Without closing the document, click on the File menu from the tool bar and verify 

whether or not the “Load Specification” and “New Specification” options are 
listed. If so, open a “New specification” and launch the template to ensure that it is 
working properly. 

If you are able to correct the problem this way, go to the Tools/Templates & Add-Ins and 
deselect the other templates each time you launch PASAT. 
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s4TEXT_Template01.dot file 
If you are missing the s4TEXT_Template01.dot file and you have all of the above 
components, do the following without uninstalling the current version of PASAT: 

1. Go to www.uspto.gov/ebc/efs/downloads/pasat.htm and click on the Agree, 
download PASAT link. This will download the Pasat.exe executable file 
- Take note of the folder to which the executable file is downloaded because you 
   will have to go back to this file to complete the installation of PASAT 
 

2. Once the download is completed, go to the folder where the Pasat.exe file was 
saved and double click on this file to execute the installation of PASAT 
- For instructions on installing PASAT, refer to PASAT v. 4.0 Installation. 

 
3. Once the installation is complete, reboot your computer 
4. When the computer has been rebooted, launch PASAT again. The errors should no 

longer occur at this point. 
If you have Document Management software or other templates loaded, after opening 
PASAT go to the Templates/Tools & Add-Ins and uncheck any templates other than the 
efs_application.dot and the s4TEXT_Template01.dot. Then go to the File drop-down 
menu and make sure the New Specification and Load Specification options are listed. At 
this point you should be able to continue using PASAT with no complications. 

Plug In 
The minimum requirement is the AlternaTIFF Plug In v1.3.5. 
Setup checks to see if the AlternaTIFF viewer is installed. If it is not, the following 
message appears: 

 

Operating System 
PASAT operates on Windows 95/98/2000 or Windows NT 4.0 with Service Pack 3.0 or 
higher.  
If the user has Windows NT, but does not have Service Pack 3 installed, the following 
message appears: 
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If the user has Windows 95, but does not have Service Pack 1 installed, the following 
message appears: 

 

Microsoft Word 
PASAT v. 4.0 requires Microsoft Word 97 with Service Release 2 or higher.  
If the user has Word 97, but does not have Service Release 2 or higher installed, the 
following messages appears: 

 

Web Browser 
PASAT v. 4.0 requires Internet Explorer 5.5 or later. 
If user has an earlier version of Internet Explorer, the following message appears: 
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If the user does not have Internet Explorer installed, the following message appears: 

 

Application Errors 
The following table outlines errors messages that may be generated by PASAT v. 4.0. 
Brief descriptions and solutions to these problems are also provided where appropriate. 

Error  Description  Solution 
Cannot add a column to a 
table that has merged 
columns. 

This occurs anytime the user 
tries to insert a column either 
before or after a column with 
merged cells. 

Split the merged cells and 
then insert a column. 

Can not cut selection  This occurs whenever a 
selection cannot be cut. For 
example, it can occur when the 
user attempts to delete a merged 
table cell. 

 

Cannot cut selection. 
Please use Table 
Menu:Delete 
Row/Column. 

This occurs when the user 
attempts to delete a table row or 
column using Cut from the Edit 
menu or the Ctrl+x shortcut. 

From the Table menu, go 
to Delete, and select either 
Delete Row or Delete 
Column. 

Cannot Delete Column.  This occurs when the user tries 
to delete: 
a column that contains merged 
cells, or 
the last column in a table. 

In the case of merged cells, 
split the merged cells and 
then delete the unwanted 
column. 
In the case where the 
column is the last one in 
the table, insert a new 
column to the right and 
then delete the unwanted 
column. If the user wants 
to delete the table by 
deleting the last column, 
they should select the 
whole table and delete it. 
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Cannot Delete Last 
Column. 

This occurs when the user tries 
to delete the last column in a 
table. 

Insert a new column to the 
right and then delete the 
unwanted column. 
If the user wants to delete 
the table by deleting the 
last column then they 
should select the whole 
table and delete. 

Cannot Delete Last Row. This occurs when the user tries 
to delete the last row in a table. 

Insert a new row below 
and then delete the 
unwanted row. 
If the user wants to delete a 
table by deleting the last 
row then they should select 
the whole table and delete. 

Cannot Delete Row. This occurs when the user tries 
to delete a row that contains 
merged cells. 

Split the merged cells and 
then delete the unwanted 
row. 

Cannot import a read 
only file! 

This occurs when the user 
attempts to import a read-only 
file. 

Change the file's properties 
to render it not read-only, 
if possible. Otherwise, find 
a non-read-only version of 
the file. 

Cannot insert 
row/column in the table 
with merged cells 

This occurs when the user 
attempt to insert a row or 
column in a table with merged 
cells. 

Split the merged cells and 
then insert the row or 
column. 

Cannot modify ID of the 
element 

This occurs when the user 
attempts to alter an ID attribute 
in the Properties dialog. 

 

Cannot Paste claims 
here. 

The user has attempted to paste 
claims in a section of the 
specification in which they are 
invalid according to the DTD. 

Find a valid position in 
which to paste claims and 
try again. 

Cannot Paste paragraphs 
here. 

The user has attempted to paste 
paragraphs in a section of the 
specification in which they are 
invalid according to the DTD. 

Find a valid position in 
which to paste paragraphs 
and try again. 

EFS Authoring Manual: PASAT v4.0 Appendix B: Error Messages 79



  
 
 
Cannot paste structured 
content at this location as 
this invalidates the 
document according to 
the DTD. 

This occurs when the user tries 
to paste structure (for example 
text and tags) in an invalid 
position according to the DTD. 

Find a valid position and 
try again. 

Cannot Paste Structure 
here. 

This occurs when the user tries 
to paste structure (for example 
text and tags) in an invalid 
position according to the DTD. 

Find a valid position and 
try again. 

Can not split current cell This occurs when the user tries 
to split a cell that has not been 
previously merged. 

Merge two table cells 
together and then split 
them. 

Can't merge more than 2 
cells. 

This occurs when the user tries 
to merge more than 2 table 
cells. 

Merge only 2 table cells. 

Doctype not supported 
by Editor. 

This occurs when the user tries 
to import a document that is not 
valid according to the PASAT-
specific DTD. 

 

Element is referenced 
Continue with deletion? 

This occurs when the user tries 
to delete a claim that is 
referenced. The user is given 
the option to delete the claim or 
to cancel the operation. 

 

@Export Error.  This error message should not 
occur. It indicates a validation 
error during export. 

Validate the document and 
correct any errors that are 
displayed. 

File already loaded.  This occurs when the user 
attempts to load a file that is 
already open in PASAT. 

 

Please see file: 
<ErrorFileName> for 
more details. 

This error occurs when 
importing an XML instance. 

Display the .err file as it 
may indicate if the error 
comes from the XML 
instance or the DTD. 
Contact i4i Support. 
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@Selected entity not 
supported by this DTD. 

This error should never occur. 
The message indicates that the 
user has tried to insert an entity 
that is not recognized by 
PASAT. 

Build a custom character in 
tiff format. 

The amount of text you 
are about to paste is 
larger than the 
recommended size 
(Approx. 50 pages). Do 
you wish to continue? 

The user has attempted to paste 
a large amount of text into 
PASAT. 

Divide the content to be 
pasted up into smaller 
sections and paste them 
each separately. 

The instance has 
validation errors, to fix 
the instance use the 
Validate Instance from 
the Tools menu. 
Continue with export? 

This occurs when the user tries 
to export a specification that is 
not valid. The user is given the 
option to continue exporting the 
specification, or to cancel the 
operation. 

Correct the validation 
errors and then export the 
specification. 

Unable to paste merged 
cells 

This occurs when the user tries 
to paste a table that contains 
merged cells. 

In the document the tables 
are being copied from, 
split the merged table cells 
before copying the table 
and pasting it into the 
specification. 

Unable to paste table. This occurs if a Paste Table 
operation is tried in an invalid 
position according to the DTD. 

Position the cursor in a 
location that is valid for 
tables to be pasted in and 
try again. 
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APPENDIX C: USPTO/PASAT LICENSE AGREEMENT 
THIS SOFTWARE IS BEING PROVIDED TO REGISTERED SUBSCRIBERS OF THE 
UNITED STATES PATENT AND TRADEMARK OFFICE (USPTO) FOR ASSISTANCE IN 
THE PREPARATION OF PATENT APPLICATIONS AND CORRESPONDENCE. THIS 
SOFTWARE IS PROVIDED UNDER THE FOLLOWING LICENSE WHICH DEFINES 
WHAT YOU MAY DO WITH THE SOFTWARE AND CONTAINS LIMITATIONS ON 
WARRANTIES AND/OR REMEDIES.  
IMPORTANT: BEFORE DOWNLOADING, INSTALLING OR USING THIS SOFTWARE, 
PLEASE CAREFULLY READ THIS LICENSE WHICH CONTAINS THE TERMS AND 
CONDITIONS UNDER WHICH YOU ARE ACQUIRING A LICENSE TO USE THE 
SOFTWARE. IF YOU DO NOT ACCEPT THE TERMS AND CONDITIONS OF THIS 
LICENSE, PLEASE DO NOT DOWNLOAD, INSTALL OR USE THE SOFTWARE AND 
PROMPTLY RETURN OR DESTROY THE SOFTWARE IF IT HAS BEEN INSTALLED. IF 
YOU DOWNLOAD, INSTALL OR USE THE SOFTWARE, YOU WILL BE ACCEPTING 
THIS LICENSE, AND YOU WILL BE CONSIDERED TO HAVE ACCEPTED AND 
AGREED TO THESE TERMS AND CONDITIONS. COPYRIGHT LAWS AND 
INTERNATIONAL COPYRIGHT TREATIES, AS WELL AS OTHER INTELLECTUAL 
PROPERTY LAWS AND TREATIES ALSO PROTECT PARTS OF THIS SOFTWARE. 
1. Definitions: TO version of the PASAT software program packaged with this License or in 
which this License is embedded, and which software program includes the storage media 
containing the software program, and any printed, online, or electronic documentation; 
2. Grant of License: Subject to the terms and conditions of this License the USPTO grants to you 
a non-exclusive, non-transferable license to (i) make copies of the Software to the extent licensed 
hereunder as necessary to exploit the User License, and (ii) use each copy of the Software 
licensed hereunder. This license includes the right to provide copies of the Software on a local 
area network. No other right to reproduce the Software is granted. Any such copies must include 
all trademarks, copyright notices, restricted rights legends, proprietary markings and the like 
exactly as they appear on the USPTO copy of the Software downloaded or received by you. 
3. Restrictions: You shall not reverse engineer, disassemble, reverse translate, decompile or in 
any other manner decode the Software. You shall not distribute, lease, rent, grant a security 
interest in, assign, or otherwise transfer the Software. You shall not modify or create any 
derivatives of the Software or merge all or any part of the Software with another program. The 
Software provided to you by the USPTO may only be used to create submissions for the USPTO 
Electronic Business Center and for access to and use with other USPTO software applications. 
4. Warranty: If the Software does not perform in substantial accordance with its accompanying 
documentation, your exclusive remedy under this agreement shall be to either (i) discontinue 
your use of the software or (ii) request that the USPTO replace the Software.  
The USPTO and its contractors do not, however, warrant that the Software will be free of all 
defects, errors or inaccuracies. The USPTO and it’s contractors shall not be responsible for any 
defects, errors or inaccuracies in the Software that result from the provision to the Software of 
inaccurate, incompatible, or incorrect data by other programs, the operating system, firmware, or 
hardware.  
5. Disclaimer of warranty: except for the explicit warranty provided in section 6, the software is 
provided "as is", without any representations, conditions or warranties of any kind, including 
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without limitation, any express or implied representations, conditions or warranties of 
merchantability, non-infringement, title, or fitness for a particular purpose.  
6. Limitation of liability: neither the uspto nor any of it’s contractors shall have any liability to 
you or any other person or entity for any damages arising from this license or related to the 
software, including without limitation any direct, indirect, incidental, special, punitive or 
consequential damages, including, but not limited to, loss of revenue or profit, loss of or 
damage to data or other commercial or economic loss, even if uspto has been advised of the 
possibility of such damages, or they are foreseeable. Specifically, the USPTO is not 
responsible for any costs including, but not limited to those incurred as a result of lost profits 
or revenue, loss of use of the software or other computer programs loss or damages, the cost of 
recovering such software or computer programs or data, the cost of any substitute program, 
claims by third parties, or for other similar costs.  
The limitations in this section shall apply whether or not the alleged breach or default is a breach 
of a fundamental condition or term or fundamental breach. Some jurisdictions do not allow the 
exclusion or limitation of liability for consequential or incidental damages, so these limitations 
may not apply to you.  
NOTE: Any USPTO liability is further controlled by Federal statute, e.g., Federal Tort Claims 
Act, 28 U.S.C. §§ 1346(b), 2671-2680 (disputes against the Government for negligent or 
wrongful acts or omissions); Big and Little Tucker Acts, 28 U.S.C. §§ 1346(a) and 1491 
(disputes against the Government concerning express or implied contracts); and the Contract 
Disputes Act, 41 U.S.C. § 601 et seq. 

7. This disclaimer of warranty and limitation of liability constitute an essential part of this 
license. You acknowledge that but for this disclaimer of warranty and limitation of liability, the 
USPTO would not grant the right to use the software as permitted in this license. 
8. Term: this license shall continue for as long as you use the software, however, it will terminate 
if you fail to comply with any of its terms or conditions. You must, upon termination, destroy all 
copies of the software. The provisions entitled title, disclaimer of warranties, limitation of 
liability and miscellaneous shall continue in force even after any termination of this license. 
9. Support and updates: this license does not grant you the right to any updates or enhancements 
of the software or the right to receive any support in respect to the software. Such updates and 
other support services may be provided to you by the USPTO. Use of such updates or 
enhancements shall be governed by the terms and conditions of this license. 
10. Miscellaneous: this license is the entire agreement between you and the uspto, superseding 
any other agreement or discussions, oral or written, and may not be changed except by a 
signed agreement. USPTO employees, contractors or their agents are not authorized to make 
any modification or addition to this warranty. 
If any provision of this license is held to be unenforceable or illegal, such decision shall not 
affect the validity or enforceability of such provisions under other circumstances or the 
remaining provisions of this license and such remaining provisions shall be reformed only to the 
extent necessary to make them enforceable under such circumstances. This license shall be 
governed by the federal laws of the United States of America. The application of the United 
Nations convention on contracts for the international sale of goods is expressly excluded. 
11. PASAT utilizes a commercial off the shelf software product called s4/text, the license for 
which is included. The s4/text run-time software license agreement is contained on the following 
page. 
12. Should you have any questions concerning this, please contact the USPTO patent electronic 
business center at ebc@uspto.gov. 
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S4/TEXT RUN-TIME SOFTWARE LICENSE AGREEMENT 
ATTENTION: THIS DOCUMENT IS A SUBLICENSE AGREEMENT (THE 
"AGREEMENT") BETWEEN YOU ("CUSTOMER"), AND UNITED STATES PATENT 
AND TRADEMARK OFFICE ("SUBLICENSOR") TO USE THE INFRASTRUCTURES 
FOR INFORMATION INC. RUN-TIME COMPUTER SOFTWARE AND RELATED 
MATERIALS. CAREFULLY READ THIS LICENSE BEFORE USING THE COMPUTER 
SOFTWARE AND RELATED MATERIALS. USING THE COMPUTER SOFTWARE AND 
RELATED MATERIALS INDICATES YOUR ACKNOWLEDGEMENT THAT YOU HAVE 
READ THIS LICENSE AND AGREE TO ITS TERMS AND CONDITIONS. IF THESE 
TERMS ARE NOT ACCEPTABLE TO YOU, PLEASE DELETE ALL COPIES OF THE 
SOFTWARE FROM YOUR SYSTEM.  
1. DEFINITIONS 
"Computer Software" Means Infrastructures for Information Inc.’s run-time computer program 
called S4/TEXT, and includes any update of, or later enhancement to, the Computer Software. 
"Related Materials" Means any documentation that explains the operation of the Computer 
Software and/or sets out any technical specifications related thereto. 
"Permitted Use" Means that, pursuant to this Agreement, Customer shall be permitted to (a) 
access and use the Computer Software in object code form, and the Related Materials, on a 
single workstation or local area network solely for Customer’s use on preparing, filing, and 
processing of patent application documents; and (b) to make copies of the Computer Software 
for backup purposes only, provided all copyright and other proprietary notices are included in the 
backup copy.  
The access and use by Customer of the Computer Software and Related Materials as described in 
this definition shall be referred to herein as the “Permitted Use.” 
2. COMPUTER SOFTWARE LICENSE 
Grant of License: Subject to the terms and conditions of this Agreement, and in consideration of 
the use of this Computer Software by Customer, Customer is hereby granted a personal, non-
exclusive and non-transferable license to use the Computer Software and Related Materials for 
the Permitted Use during the Term of this Agreement. All rights not expressly granted to 
Customer by this Agreement are reserved by Sublicensor. 
Restrictions on Use: Customer may only make copies of the Computer Software and Related 
Materials for the Permitted Use and only to the extent necessary for the Permitted Use. Customer 
shall not: (a) adapt, change, or otherwise modify the Computer Software; (b) remove any product 
identification, copyright notices or other notices or proprietary restrictions from the Computer 
Software or the Related Materials; (c) permit any third party to use, read or otherwise gain access 
to the Computer Software or the Related Materials; (d) further sublicense or use the Computer 
Software for commercial timesharing, rental or service bureau use; (e) perform any act, nor 
permit any act to be performed by a third party, that would harm, or in any way negatively affect 
or diminish Infrastructures for Information Inc.’s intellectual property rights in the Computer 
Software or Related Materials, including the copyright, patent, trade-mark, trade secret or other 
rights in law or equity of Infrastructures for Information Inc.; (f) cause or permit the reverse 
engineering, disassembly, or decompilation of the Computer Software. 
3. OWNERSHIP 
Customer acknowledges that, save and except for the license explicitly granted by this 
Agreement, all right, title and interest in and to the Computer Software, Related Materials, and 
all other S4/TEXT materials supplied under this Agreement, including but not limited to, patent, 
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trade-mark and copyright rights in S4/TEXT are, and shall remain, the exclusive property of 
Infrastructures for Information Inc. 
4. TERM AND TERMINATION 
This Agreement is effective until terminated (the “Term”), and shall terminate automatically if 
Customer fails to comply with the terms and conditions set out in the Agreement. Either 
Sublicensor or Infrastructures for Information Inc. may terminate this Agreement for such non-
compliance. Upon termination or expiration of this Agreement for any reason whatsoever, 
Customer shall cease to have any rights to access and use of the Computer Software or Related 
Materials, shall immediately destroy all copies of the Computer Software and Related Materials 
in the possession of Customer. All copies of the Computer Software and Related Materials shall 
be removed from any storage media before disposal of such media by Customer. 
5. WARRANTIES AND LIMITATION OF LIABILITIES 
All materials provided to customer are provided “as is” and neither sublicensor nor 
infrastructures for information inc. shall be liable for any indirect, incidental, special or 
consequential damages, damages for loss of profits, revenue, data or data use, incurred by the 
customer or any third party, whether in an action in contract or tort, even if sublicensor has been 
advised of the possibility of such damages. Liability of sublicensor and of infrastructures for 
information inc. for damages hereunder shall in no event exceed the fees paid by customer for 
this license.  
Sublicensor does not warrant that: computer software will meet customer’s requirements, that 
programs will operate in combinations the customer may select for use, that operation of 
computer software will be uninterrupted or error-free, or that all errors will or can be corrected. 
There are no warranties, whether express or implied, including, without limitation, warranties of 
merchantability and fitness for a particular purpose. 
Any Sublicensor liability is further controlled by Federal statute, e.g., Federal Tort Claims Act, 
28 U.S.C. §§ 1346(b), 2671-2680 (disputes against the Government for negligent or wrongful 
acts or omissions); Big and Little Tucker Acts, 28 U.S.C. §§ 1346(a) and 1491 (disputes against 
the Government concerning express or implied contracts); and the Contract Disputes Act, 41 
U.S.C. § 601 et seq. 
6. GOVERNING LAW 
This Agreement shall be governed by and interpreted under applicable federal laws. 
7. ASSIGNABILITY 
This Agreement is binding on both the parties to this Agreement, their successors and assigns 
and may not be assigned, conveyed or otherwise transferred by Customer without Sublicensor’s 
prior written consent.  
8. GENERAL PROVISIONS 
This is the entire agreement between Customer and Sublicensor pertaining to Customer’s right to 
use the Computer Software and Related Materials, and supersedes any other agreement or 
discussions between the parties, oral or written, and cannot be amended or modified other than 
by the written agreement of the parties. In the event that any portion of this Agreement is held by 
a court of competent jurisdiction to be invalid or unenforceable, then the remaining provisions of 
the Agreement shall survive unaffected. Without limiting any remedy to which Sublicensor may 
be entitled, Customer agrees Sublicensor shall be entitled to equitable relief. 
9. SURVIVAL 
The obligations and covenants of the parties described in Section 1, Section 3, Section 5, Section 
6, Section 8, and this Section 9 shall survive the termination of this Agreement for any reason 
whatsoever. 
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